The Last Stand: Aftermath – Game Freezing

How to Fix Game Freezes

Try the following troubleshooting steps:

  • From the main menu, go to Options -> Video. On this page, change the toggle setting for VSync to the opposite of what you currently have it set to.
  • If the issue persists, from the same Video options page, please try limiting FPS to 60.
  • Also on the same page, you can try to limit screen resolution to no more than 1920×1080.
  • Make sure to verify that the drivers for your graphics card are up to date. If you know your graphics card, you should be able to Google how to update the drivers on it, or you should have something like NVIDIA already installed on your PC to assist with updating drivers.
  • Make sure you have DirectX 11 (or higher) installed.
  • Update your C++ Redistributable: https://docs.microsoft.com
  • Update your .NET Framework: https://catalog.update.microsoft.com
  • Disable any anti-virus software you have running or add TLSA.exe as an exception on the software.
  • Close or turn off MSI Afterburner, if you have it running, or other GPU monitoring software.

Another possible fix is to make sure that you are running the game as an Administrator on your PC. If you do not have write permission to local storage, the game may not properly function. To do this, you can launch the game directly via:

  • …/Steam/steamapps/common/The Last Stand Aftermath/TLSA.exe

And you’ll want to right click on that file, and then Run as Administrator.

Lastly, a user has suggested these steps to try:

  • Go to ../Steam/Steamapps/Common/The Last Stand Aftermath.
  • Right click on TLSA.exe > click on properties > go to compatibility tab > change settings for all users > enable Run this program as admin > enable “Disable Fullscreen Optimization”.
  • On the same tab, click on change high DPI settings > Enable Override high dpi scaling behavior and click application.

Recommended for You

7 Comments

  1. Right after installing, it would just crash when launched. I rebooted, it would run but the game would start with a black screen (you could hear sound effects). I basically made all graphics settings “lowest” quality and rebooted a few times. Now it runs.

    The game seems not good at figuring out the right balance of effects and performance – I had to manually adjust graphics quality features to find a combo that did not crash or give a black screen. It now runs, but it was no fun spending an hour F’ing around with these settings. I appreciate the helpful tips they added to the settings though, so that’s nice.

    Also I REALLY wish they had a feature to let us turn off the wind blown grass and rain. My laptop isn’t *that* bad but the game is super demanding on graphics, and when I’m in a scene with lots of grass and rain, performance is horrible with almost unplayable lag. In a setting with more concrete decorations – no waving trees and stuff, the performance is great. So if you don’t have a really good graphics card, be prepared for a pretty bad experience.

  2. Since I lowered the overall quality, the game seems to be playable without crashing, although crashes at startup still seem to happen (it happened twice, for me, one of them causing a BSOD)

    I don’t know what’s wrong with this game, but there seems to be a problem with resource consumption
    In ultra, my card went up to 75°, and even now, in low, it goes up to 55°, it seems very excessive
    As an example, Genshin Impact, in ultra, barely exceeds 50°, Kena in ultra rarely exceeds 65°.

    It seems to consume, regardless of the power of the components (in my case, this is what causes me to worry, I know my graphics card doesn’t like it)

  3. try to go to properties > compatibility > change settings for all users > enable Run this program as admin > enable “Disable Fullscreen Optimization”

    > click on change high DPI settings > Enable Override high dpi scaling behavior and click application.

    above steps works if ever my games are not working properly.

  4. I think i found a “fix” for this issue… This is a RAM issue… Close all your apps, lower all your graphics to the minimun and try again… Sorry for my bad english….

  5. I have done what the comment thread suggested. I am now able to skip the cut scene but now it is stuck on the Black Screen after the Cut scene Dialog for the very beginning of the game. I really dont want to request a refund due to me enjoying this game series.

  6. me too, black screen after the text-intro. i can hear rain and a radio noise. tried the tasslefoot’s suggestions, didn’t work.

  7. Got an error on the 5th time of trying: “The instruction at 0x00007FFC30CA51A3 referenced memory at0x00000000000. The memory could not be read.”

Leave a Reply

Your email address will not be published.


*